Repository navigation
MAINT: Use safe pip - #79
Merged
Merged
Conversation
charris
force-pushed
the
update-pip-2.5.x
branch
4 times, most recently
from
October 25, 2026 04:23
6ad1682 to
9caf268
Compare
Pip needs to updated to a secure version on account of the eMudhra compromise. This does this by creating a script to install the safe version, and then running the script where needed. Two files are affected: - tools/wheels/bootstrap-pip.sh # install secure pip - github/workflows/wheels.yml # runs the script where needed Pair programmed with Grok.
charris
force-pushed
the
update-pip-2.5.x
branch
from
October 25, 2026 05:14
9caf268 to
fea0a8c
Compare
rgommers
approved these changes
Oct 25, 2026
rgommers
left a comment
Member
There was a problem hiding this comment.
Thanks @charris. This works, and given that it's 2.5.x-only I think it's fine to merge this, because long-term maintainability isn't much of a concern.
The cleaner fix is probably to stop using the image's python/pip though, and directly install a known-good interpreter:
- name: Setup Python
uses: actions/setup-python@5fda3b95a4ea91299a34e894583c3862153e4b97 # v7.0.0
with:
python-version: "3.14.9"
But either way, let's get this in - if you're happy with this fix, so am I.
2 tasks done
Member
Author
|
@rgommers There is no safe version of Python 3.12, which we still support in NumPy 3.5 and 3.6. The method here should be good at least until all the runners are safe. My thought is less about numpy-release, where either is a good solution, and more about numpy itself. |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Pip needs to be a secure version on account of the eMudhra compromise. This PR does that by creating a script to safely install the safe version, and then running the script where needed. Two files are affected:
Only the sdist build needs fixing, the other pip calls occur in the cibuildwheel environment which is set up to use a safe pip by cibuildwheels >= 4.3.3.
Pair programmed with Grok.